Recent Posts

Pages: [1] 2 3 ... 10
1
I don't.  I have read a bit about it, but nothing more than that.  I am not sure it is even in production any longer.
2
General Tech Talk / Anybody have experience with overkill intake manifold?
« Last post by TRBO55 on Aug 15, 2017, 06:40 AM »
Any info or input
3
Thats tough to say.  I prefer AC Delco for sure, but with the price difference thats hard to swallow.  Had you thought of finding a local CV Joint repair place to see if they can rebuild yours or check them to see what is going on?
4
I think I found culprit. Today I crossed through a light and there was a dip in road on other side. Well car made noise like running over a cinder block. I tore front apart in the rain n found that my cv shafts do have lot of play. Up n down side to side. Drivers side is a lot worse. So I guess I'll be replacing both. Ac delving is over $200 per shaft. And don't even say new. The option below that is cardone. Rebuilt or new made by cardone. Which is better?  Or Is it actually worth almost 4x the price for ac delcos? Any opinions.
5
Events & Gatherings / Michigan Monte Carlo Club's 6th An. Fall Meet
« Last post by 06mistreSS on Jul 21, 2017, 07:49 AM »
Calling all Monte Carlo owners! Michigan Monte Carlo Club is returning to mid-lower Michigan for our 6th Annual Fall Meet at Bennett Park in Charlotte, Michigan. Our annual meets are free and open to all Chevrolet Monte Carlo owners, both members and non-members of Michigan Monte Carlo Club. All years and generations from 1970 to 2007 are welcome. Please let us know if you plan to attend as this helps with planning!

When | Saturday, August 26, 2017
10 am to 3 pm

Where | Bennett Park
1305 Cochran Ave.
Charlotte, Michigan 48813

- Free and open to Club members and non-members
- Park entry free
- Awards for Top-3 Montes
- Dash plaques for first 15 Montes
- Door prizes
- Club t-shirts available to purchase ($20 ea.)
- Pot-luck lunch

Facebook Event Page | www.facebook.com/events/147933089110563

Directions | From I-69 exit 60 head west on M50 (Shephard St), turn left at Cochran Ave and the Park will be 0.5 mile on the left (look for signs).
6
LS4 Engine / Re: DOD delete and Cam Question
« Last post by LeadfootCJ7 on Jun 17, 2017, 04:34 PM »
Interesting.  I haven't looked to deeply into DOD delete myself.  Most people do a DOD cam or a full DOD delete so I am not sure I have ever heard if those would work together.
7
LS4 Engine / DOD delete and Cam Question
« Last post by AZLS4 on Jun 04, 2017, 10:28 PM »
So a guy that lives in my area offered to sell me a lot of stuff that he was going to put on his GXP but ended up not doing it. Cam, DOD delete kit, Beehive Valve Spring Kit, Rocker Arm retro fit Trunnion Kit, and Hydraulic Roller Lifters. I think that's everything. My question is, for the dod delete kit (#09-0026) and cam (#646-433-13), will they work together? The delete kit calls for a non DOD cam, but the cam he has says it does work with DOD. I asked him about it and he said that everything he has there will work fine. I just wanted some input, if you guys type in the part numbers I listed it should bring up the parts online. Thanks for any help.
8
LS4 Engine / Re: Upper mount(dogbone)
« Last post by Monster762 on Jun 04, 2017, 08:58 AM »
Lower mounts were replaced a couple months back when I had engine dropped and oil pump replaced. It was only getting 7 pounds pressure at idle. I'll check them though cause I'm about to jack up to check what sounds like bad strut.
9
LS4 Engine / Re: Upper mount(dogbone)
« Last post by LeadfootCJ7 on May 31, 2017, 03:00 PM »
Some people make poly mounts and they supposedly last a long time.  The rubber should last longer than you are seeing.  If they are going bad that quick, your lower mounts are most likely toast and need to be replaced along with the upper.
10
LS4 Engine / Upper mount(dogbone)
« Last post by Monster762 on May 29, 2017, 06:33 AM »
I have 06 impala ss. Is there any real mount for front top?  I've looked everywhere online and even those garbage poly mounts don't last 6 months. Sometimes short as 3 months. Has anyone had success with anything permanent there? Random replacing is no good. All other mounts fine just top keeps going. Quickly. And then I have to drive around with engine moving literally hear the metal in mount clank when taking off even slowly. It also causes slight delay which can't be good on other parts to jerk almost like trans jerk. It's just so often someone has to have found a permanent solution. I have tried all poly bushings n all. Some of which are weaker than the rubber ones. A rubber mount is only $7 it's just the week waiting for it randomly. Or auto store will want $50+ for it and most won't have it in stock either.
Pages: [1] 2 3 ... 10