Author Topic: P0521 2005 GP GXP  (Read 333 times)

0 Members and 1 Guest are viewing this topic.

Offline dcjemm

  • Trade Count: (0)
  • Floor Sweeper
  • *
  • Join Date: Nov 2017
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Country: us
P0521 2005 GP GXP
« on: Nov 27, 2017, 12:06 PM »
2005 Pontiac Grand Prix GXP

I've changed my oil pressure sensor 3 times. I've changed the filter three times. Still getting the code p0521. When I bought the car the previous owner had installed a new pigtail. I'm not sure he connected it correctly. Through reading the forms I've checked and I am almost positive that I have the wires connected correctly, I think. I've checked the resistance of the power line vs the signal wire and ground. I know my vehicle has three wires on that pigtail. I've seen other vehicles for example the 2008 Grand Prix GXP with only 2 wires on the oil pressure sensor. Could someone please shed some light on how many wires I should have for the pigtail and the proper color code. I know I'm supposed to have black gray and brown but it appears that I have black brown and brown with a light brown stripe. And yes I have checked my oil pressure and it is exactly where it's supposed to be.

Offline LeadfootCJ7

  • Trade Count: (0)
  • Helper
  • **
  • Join Date: Sep 2013
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 70
  • Country: us
Re: P0521 2005 GP GXP
« Reply #1 on: Dec 01, 2017, 09:37 AM »
What brand replacement sensor and filter are you using?  I would have to look under my hood later to see what the wire colors are.

Offline LeadfootCJ7

  • Trade Count: (0)
  • Helper
  • **
  • Join Date: Sep 2013
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 70
  • Country: us
Re: P0521 2005 GP GXP
« Reply #2 on: Dec 05, 2017, 01:16 PM »
My sensor has 3 wires.  Black, white, and tan.  Mine is a 2007.