Author Topic: Upper mount(dogbone)  (Read 139 times)

0 Members and 1 Guest are viewing this topic.

Offline Monster762

  • Monster762
  • Trade Count: (0)
  • Helper
  • **
  • Join Date: Jul 2015
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 88
  • Country: us
Upper mount(dogbone)
« on: May 29, 2017, 06:33 AM »
I have 06 impala ss. Is there any real mount for front top?  I've looked everywhere online and even those garbage poly mounts don't last 6 months. Sometimes short as 3 months. Has anyone had success with anything permanent there? Random replacing is no good. All other mounts fine just top keeps going. Quickly. And then I have to drive around with engine moving literally hear the metal in mount clank when taking off even slowly. It also causes slight delay which can't be good on other parts to jerk almost like trans jerk. It's just so often someone has to have found a permanent solution. I have tried all poly bushings n all. Some of which are weaker than the rubber ones. A rubber mount is only $7 it's just the week waiting for it randomly. Or auto store will want $50+ for it and most won't have it in stock either.
06 impala ss  factory bose rear deck jbl doors with sundown audio sub,3cubic ft band pass alpine amp, 20% tint , a lot of suspension redone with Moog,kyb struts ,drilled slotted rotors,carbon pads,black headlights,rebuilt trans, backyard intake w/K&N filter,3 in exhaust all the way back. Dod delete(software not hardware). P zero tires factory rims

Offline LeadfootCJ7

  • Trade Count: (0)
  • Helper
  • **
  • Join Date: Sep 2013
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 63
  • Country: us
Re: Upper mount(dogbone)
« Reply #1 on: May 31, 2017, 03:00 PM »
Some people make poly mounts and they supposedly last a long time.  The rubber should last longer than you are seeing.  If they are going bad that quick, your lower mounts are most likely toast and need to be replaced along with the upper.

Offline Monster762

  • Monster762
  • Trade Count: (0)
  • Helper
  • **
  • Join Date: Jul 2015
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 88
  • Country: us
Re: Upper mount(dogbone)
« Reply #2 on: Jun 04, 2017, 08:58 AM »
Lower mounts were replaced a couple months back when I had engine dropped and oil pump replaced. It was only getting 7 pounds pressure at idle. I'll check them though cause I'm about to jack up to check what sounds like bad strut.
06 impala ss  factory bose rear deck jbl doors with sundown audio sub,3cubic ft band pass alpine amp, 20% tint , a lot of suspension redone with Moog,kyb struts ,drilled slotted rotors,carbon pads,black headlights,rebuilt trans, backyard intake w/K&N filter,3 in exhaust all the way back. Dod delete(software not hardware). P zero tires factory rims